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From Frontend to Backend,
Build Complete Web Solutions
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RAISE TECH

Raise Tech Talents Core and advanced Java course is aligned to Industry
standards developed by leading Java Experts. This course aims to make
vyou master all the Core and Advanced level skills in the Java and various

technologies involved in the field of Java

£ Fullstack

COURSE DURATION SESSION HOURS
150 DAYS 450 HOURS
\v/Z2l KEY HIGHLIGHTS

Institute backed by strong IIT alumina Team
More than 10,000 + success stories created

Partnered and serving 100+ clients right from the inception of the firm

Parent company Quality Thought No #1 providing placements since 2010

Experienced IT Architects, subject matter experts as advisory in the board
Guaranteed Internship Opportunity (3 to 6Months) for every participant

Backed by strong Internal human resource team enabling quick placements

/
/
/
/
/
/
/
/

Special guidance to students to win jobs with highest packages

(&M TRAINING HIGHLIGHTS

> Industry ready course roaster desighed by > Access to Instant recorded live
architects and subject matter experts Class videos shared

> Proven content, creating gateway to > Personalized attention and guidance
world of Job opportunities to accelerate the learning

> Practical & detailed approach, everyone > Member access to private group to
can understand and perform to excel get instant doubt clarifications

>  Subject matter experts as trainers > Guest lectures from leading

. . . MNC Companies
> Not just learning, Learn by doing methodology
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RAISE TECH

Core Java

[quter the Funhdamentails. Build Strong Logic.j

Basic Introduction of Java OOPS

> Programming Language > Main method > Class > Method Overriding
> Modules In Java > System.out.printin() > Objects > System.out.printin()
> History of Java > Command line arguments > Data Hiding > Method Hiding

> Internal Architecture of JVM > Java Source File Structure > Abstraction > Polymorphism

> Naming Conventions > Types of Blocks in Java > Encapsulation > Constructors

> Identifiers > Type casting in Java > Is-Arelationship > This keyword

> Reserved Words > Fully Qualified Name > Has-A relationship > Super keyword

> Data-types > Import Statements > Types of inheritance 2 Interfaces

> Types of variables > Control-Statements > Types of variables > Abstract classes

> var-arg method > Arrays > Method Overloading > Wrapper classes

Exception Handling @ Java.io Package
> Exception vs Error > Finally block > File > Print Writer
> Types of Terminations > Types of Terminations > File Writer > Various ways to provide
> Exceptions Hierarchies > Throw statement > File Reader Inputs
> Try block > Throws statement > Buffered Writer
> Catch block > Buffered Reader

Collections
> Thread vs Process > Thread priority
> What is Collection? > Map interface > Multi-Tasking > Types of cursors in Java
% List interface > Types of cursors in Java > Multi-Threading > Various methods to prevent

> Ways to start a thread in java  a thread from execution

> Set Interface
> Daemon Thread

> Setting and Getting name
of a thread > Synchronization
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RAISE TECH

racle

Master Oracle Database with our comprehensive
SQL & PL/SQL training. Build strong database
skills for real-world applications.

> Types of Data Y Introduction to PL/SQL
» Introduction to Oracle
y Tables, DBMS, RDBMS » Control statements in PL/SQL
» DDL commands ,

> Loops in PL/SQL
» DML commands
) DRL commands > DML operations in PL/SQL
» DRL commands with where clause
y TCL commands > DRL operations on PL/SQL
» DCL commands , ,

) Exception Handling
» Operators in SQL
) Group by, Having and order by clause ) Cursors
» Integrity constraints

Procedures

» Types of constraints )
) Joins ) Functions
» Sub Queries
) Sequences ) Packages
> Synonyms

) Triggers
) Pseudo columns
> Indexes

@ Build a strong foundation in ﬁ Enhance your programming sKills

database management using SQL. with PL/SQL for complete solutions.
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Advanced JAVA

a) JDBC

> Introduction to JDBC

> JDBC Drivers Architectures
> Files vs Database

> Connection object

> Types of Statement objects
> Types ResultSet objects

> Select query executions

b) Servlets

> Non-select query executions
> Working with Date values

> Working with LOB values

> Database Metadata

> ResultSet MetaData

> Batch Processing

> Transaction Management

> What is web application?

> What is web resource program?
> What is web container?

> Sample web application creation
> Types of url patterns

> MIME Types

> Types of Communications

> Servlet Filters
> Servlet Life cycle methods
> ServietConfig object

> ServietContext object

RAISE TECH

> Stateless Behavior of web application

> Session Tracking

> Introduction to JSP

> JSP life cycle

> JSP Tags

> JSP to Database communication
> JSP to Java Bean communication

> MIME Types

d) Servers

> JSP impilicit objects

> JDBC Connection pooling
> JSP MVC Architecture

> Working with IDE's

> Types of Communications

> Tomcat Server > Web Logic Server
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RAISE TECH

e Whatis SDLC
* Types of phases in SDLC /

e Eclipse

* NetBeans /

f) Real tools ~N

h) Project N

e Module 1

e GIT/GITHUB

e Maven/Gradle

\_ e Junit W,

e Module 2 /

Java Framework ¢

Spring Boot Spring Data JPA

Spring Data JPA
Introduction

Introduction

. . Features of spring data JPA
Spring vs Spring Boot Piing
Working wiht H2 database

Spring Modules overview
Working with MySQL database

Spring MVC architecture Project Lombok

What is Spring Boot CURD operations

Advqntqges of Spring Boot Exception Handling in Spring Boot

RestTemplate

Spring Boot Architecture
WebClient

Spring Boot Application using Initializr Flyway Database Migration

Spring Boot Application using STS IDE Spring Boot Caching

Spring Boot Annotations Swagger

: . : Spring Boot Actuators
Properties file vs YAML file

Spring Security

Spring Boot starters
Pring Authentication

Authorization

VvV V VvV V V V V V V V VYV
vV V V V VvV VVV VV VV YV VYV

Spring MVC Application

Spring Web

Introduction to Spring web
Web Application Development

application.properties file

Web annotations

Spring Boot Thymeleaf

VoV VVVV

Spring Boot Thymeleaf to interact with H2 Database

/
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RAISE TECH

Spring Micro-Services

a) Introduction

> Monolithic Architecture > Micro Service Architecture
> Micro service communication > Creating micro services using spring boot
> Spring Cloud API Gateway > Service Registery (Eureka Server)
> Hystrix in microservices > Loading Balancing using Ribbon
> Types of Statement objects > ResultSet MetaData
> Zipkin and Sleuth > CloudConfig
b) IDE’'S
> Spring Tool Suit (STS) > Intellid

c) Embedded Servers

> Tomcat, Jetty, Undertow

d)Embedded Databases
> H2, HSQL, Derby

e) Tools
> POST MAN

Web Development

a) Introduction

> What is HTML5? > Types of Browsers?

> Types of Search Engines? > What is Web site?

> What web page? > Simple HTML skeleton program
> Comments in Java > HTML5 Meta Tags

> HTML Basic Tags > Phrase Tags in HtmI5

> HTML Colors > HTML Images

> HTML Hyperlinks > Listin HTML

> HTML Tables > Block Elements vs Inline Elements
> HTML forms > GET vs POST methodology

> HTML datalist Tag > Frames

> <iframe> tag > HTML Audio

> HTML Video > Graphics in HTML

> HTML Layouts

b) Editors
> NotePad > NotePad++

e 9642210326

9 #304, 3rd floor, Nilagiri Block
Beside Metro station, Ameerpet, Hyderabad.



RAISE TECH

CSS-3

® 6 0 0 o N
b) Editor
a I > VSC ( Visual Studio Code)
a) Introduction
| ,/
> What is CSS? ~
> Types of CSS?
> CSS background property c) Task
> CSS borders % Task 1
> CSS margins > Task 2
> CSS paddings > Task 3
> CSS ID selector \_ %
> CSS Class selector a N
> CSS Height and Width
> CSS overflow property BOOtSta p - 4
> CSS border-radius property
> CSS box-shadow property
> CSS float property
> CSS list property B a) Introduction
> CSS tables ,
. > What is Bootstrap
display propert
? DIy PIOpETtyY > Advantages of Bootstrap
> CSS transform property
> Bootstrap buttons
> CSS transition property
> Bootstrap alerts
> CSS position property
> Bootstrap badges
> Bootstrap dropdown
b) CSS Design Work > Bootstrap grid system
> CSS Design 1 > Bootstrap navbar
> CSS Design 2 > Bootstrap tables
> CSS Design 3 > Bootstrap cards
> Bootstrap forms
c) Editors > Bootstrap pagination
> > Sublime > Bootstrap progress bar
> Bootstrap carousel
N /
4 A
Java Script b) Design
l' > Designs 1
a) Introduction > Designs 2
> Designs 3
Introduction to JavaScript \_ -

Types of JavaScript

&

JavaScript variables

JavaScript strings
JavaScript operators
JavaScript validation
JavaScript loops
JavaScript arrays

JavaScript functions

JavaScript events

JavaScript form validation

vV VvV VvV VvV VvV VvV V V V VYV YV

JavaScript regular expression
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RAISE TECH

React/ ReactJS

a React Introduction Custom hooks

© Advantages of React

React Router

© JsXIntroduction Lists in React

@ Expressionsin JSX
© JSXelements

Key Iin React

Assets in React

© React virtual DOM Bootstrap in React

€@ First application development in react React Forms

© React project structure explanation Axios

© React Fragment ReactJS + NodeJsS +

@ Componentsin React MYSQL database

@) Function component vs Class component Integration

©® Props
@ state

@ Composing component
@ CssinReact

@ Type checkingin props
@ ReactJs vs React Native
@ ReactJs vs AngularJs

React Redux

@ Event Handing in React
€9 Update state using event handling

€¢) Phases of components in react

€ Life cycle methods in react
€® Hooks introduction
€D Predefined hooks

e 9642210326
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RAISE TECH

Types of Applications AWS EC2 Instance
PC vs Server Types of instances in AWS
Need of Cloud Infrastructure AWS Tenancy

What is Cloud Computing AWS Launch Template
What is AWS? And Why to choose AWS AWS EBS volumes

How to create an account in AWS Need of Elastic IP Address

What an Operating System AWS RDS service for JDBC

and its types Application?

Importance of Linux in How to deploy web

Cloud Environment application in AWS Elastic
Bean Stalk

How to create a Linux server in AWS AWS S3 service

Putty vs Xshell How to deploy spring boot

application in AWS Cloud

s 9642210326
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RAISE TECH

? (Al Aritificial Intelligence (Al) with open Al (Tools)
& NLP & Data Structures &Algorithms

1. Applications of Al 1

» Applications of Al
» History of Al

> Types of Al

» Future of Al

> Type of Agents

A. Intelligent Agent
B. Agent Environment
C. Turning Test in Al

2. Problem Solving in Al 1

i &

vV v Vv Vv V¥

Search Algorithm

Uninformed Search Algorithm
Informant Search

Algorithm Hill Climbing Algorithm
Mean End Analy

3. Adversarial Search 1

» Adversarial Search
» Minimax Algorithm
» Alpha-Bete Pruning

4. Knowledge Represent 1

E G

vV v Vv Vv V¥

Knowledge based Agent
Knowledge Representation
Propositional Logic

Rule of Inference

First Order-logic

5. Uncertain Knowledge R 1

@

» Probabilistic Reasoning in Al
» Bayes Theorem in Al
» Bayesian Belief Network

6. Unification in FOL 1
» Resolution in FOL

» Forward Chaining and Backward Chaining
» Backward Chaining and Forward Chaining
» Reasoning in Al

» Inductive vs Deductive sing

9642210326
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RAISE TECH

Al (Artificial Intelligence)

> Example of Al > Alin Healthcare
> Alin Education > Alin Agriculture

> Alin Engineering Applications > Al and Robotics

> Scope of Al > Agent of Al

> Alin Stock > Al as services

> Alin Banking > Cognitive Al

> Alin Automotive Industry > Al in Manufacturing Industry
> Alin Civil Engineering > Alin Gaming Industry

> AIHR > Alin Medicine

> Alin Marketing > Chat Completion

> Embedding > Text to Image

> Audio Transcription > Text to Speech

> Moderation

> Instruction to Data Structure > Algorithms

- > Performance Analysis > Asymptotic Notations

> Arrays > Structures

- > Pointers > Dynamic Memory allocation
> Stocks Implementation > Stock Implementation using pointer
> Queues > Double Ended queue (Deques)
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CRT, VERBAL & SOFT SKILLS

APTITUDE

RAISE TECH

VERBAL (ENGLISH)

DEWEOEREHEEm MO =

Number system
(Divisibility ,LCM & HCF,

Decimal Fraction,Power..)

Time & work

Speed & Distance

Profit and Loss

S| and Cl(Interest)

Permutation
and combination

Probability

Percentages

Averages

Ratio and Proportion

Coordinate and
Quadratic Equations

A.Pand G.P

Allegations and Mixture

Boats and Streams
Area & Perimeter

Miscellaneous topics
(Ages, clock &
Calender, Geometry

DI (Data
Intrepretation

BIOLUICIICIOIOROIOICICONCY

Statement &
Conclusion

Coding & Decoding

Seating Arrangement
(Linear and Circular)

Analogy Pattern
(Word and Number)

Odd man out &
Number Series

Distance and Direction

Logical word Sequence

Blood Relation

Symbols and
Notations

Rank based Logic

Data Sufficiency

DI (Pie and Bar graph)

Miscellaneous topics
(if any)

DIOIDIOIONOIOIOSIGIOIGIOION)

Reading
Comprehension

Article , preposition

Direct & Indirect
speech

Active and Passive

Tenses

Vocab- Synonym and
Antonym (On a daily basis)

Spelling text
Idioms and Prases

Spotting Error

Fill in the blanks

Sentence Improvement
and Sentence Completion

Parajumble Sentence

Word Substitution

Model Auxiliary verbs

Miscellaneous topics
(Verbs, Conjunction..)
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LEARN TODAY,

We bridge the gap between learning

EMPOWERING FUTURE and real-world application with

hands-on training and placement

T E C H L E A D E R S focused programs.

7~ . EXPERT TRAINER
«O) S -

At RaiseTech, we transform beginners into . .
(@R Learn from experienced industry

Industry-ready professionails through rofessionals,
practical learning, real-world projects,
and expert mentorship. PRACTICAL LEARNING

Work on real-world projects and

industry case studies.

PLACEMENT SUPPORT

Resume building, mock interviews
& placement assistance.

WHY CHOOSE RAISETECH? . _ ifi?flfﬂiﬂd certification

to boost your career.

INDUSTRY RELEVANT CURRICULUM

Our curriculum is designed as per the
latest industry standards.

HANDS-ON EXPERIENCE € Java Full Stack Development
Gain practical skills through real-time ﬂ P‘}fthDI‘I Full Stack DE"J‘E‘|D[]-FI"IEI']'|I
. projects and assignments.
| € MERN Stack Development
CAREER FOCUSED TRAINING € Data Science & Machine Learning
We focus on building job-ready skills & Cyber Security
| and career growth.
' @ Cloud Computing (AWS)
GROW WITH CONFIDENCE ® UI/UX Design
From basics to advanced, we help you |
grow step by step. ©@ Data Analytics
WHAT YOU WILL LEARN
/> i :
= >
PROGRAMMING WEB DATABASE REAL-WORLD DEPLOYMENT
FUNDAMENTALS DEVELOPMENT MANAGEMENT PROJECTS & DEVOPS
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